云服务器部署Jenkins
2026/9/24 17:49:36 网站建设 项目流程

Jenkins官网:

安装JenkinsJenkins 是一个开源自动化服务器https://www.jenkins.io/zh/doc/book/installing/docker镜像:

https://hub.docker.com/r/jenkins/jenkins/tagshttps://hub.docker.com/r/jenkins/jenkins/tags

通过item登录到服务器

可以参考item配置自动连接服务器:

mac中iTerm有没有类似xshell远程连接服务器的用户名密码方式,不用每次都要输入用户密码-CSDN博客文章浏览阅读253次,点赞5次,收藏5次。本文介绍使用sshpass工具实现Mac终端SSH自动登录,无需交互输入密码。同时提供iTerm2集成sshpass的配置教程,实现快速连接远程服务器,提升工作效率。本文介绍了如何在Mac上使用iTerm2进行SSH连接,包括下载安装iTerm2,新建配置文件(profile),设置命令行连接命令,以及通过编辑Triggers自动发送密码,实现类似Xshell的便捷登录功能。发现一个不错的方式, 在iTerm2中通过添加Profiles的方式,直接点击自动连接远程服务器。https://blog.csdn.net/guo13313/article/details/164095439?ops_request_misc=elastic_search_misc&request_id=2766104850c42c96ab41b0e97d203dc6&biz_id=0&utm_medium=distribute.pc_search_result.none-task-blog-2~all~ElasticSearch~search_v2-1-164095439-null-null.541^v3^pc_search_result_blog8&utm_term=iterm&spm=1018.2226.3001.4450

ssh -p 22 root@8.160.170.127

docker安装jenkins命令

docker run \

-u root \

--name=myjenkins \

--restart=always \

-d \

-p 8080:8080 \

-p 50000:50000 \

-v jenkins-data:/var/jenkins_home \

-v /var/run/docker.sock:/var/run/docker.sock \

jenkinsci/blueocean:1.25.5

注意上面命令 \ 后面不能有空格

安装完成后:

服务器安全组,增加入口8080规则

访问

查看密码

docker logs myjenkins

安装推荐的插件

等待插件安装,重试了好几次,一直失败,更换了镜像重新执行了上面的流程最终成功了

版本太低的一些错误日志: Caused by: java.io.IOException: commons-lang3 v3.x Jenkins API Plugin v3.20.0-109.ve43756e2d2b_4 failed to load. - You must update Jenkins from v2.150.1 to v2.479.3 or later to run this plugin. at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:652)

https://hub.docker.com/r/jenkins/jenkins/https://hub.docker.com/r/jenkins/jenkins/

docker run \

-u root \

--name=myjenkins \

--restart=always \

-d \

-p 8080:8080 \

-p 50000:50000 \

-v jenkins-data:/var/jenkins_home \

-v /var/run/docker.sock:/var/run/docker.sock \

jenkinsci/blueocean:1.25.5

jenkins/jenkins:2.583

或者 docker-compose.yml

services: myjenkins: # image: jenkinsci/blueocean:1.25.5 # image: jenkins/jenkins:2.504.1-lts image: jenkins/jenkins:2.583 container_name: myjenkins restart: always user: root ports: - "8080:8080" - "50000:50000" volumes: # 沿用原有持久卷,数据不丢失 - jenkins-data:/var/jenkins_home # 支持容器内调用docker - /var/run/docker.sock:/var/run/docker.sock environment: TZ: Asia/Shanghai volumes: jenkins-data:

少BlueOcean,下载BlueOcean主插件

少阶段视图,安装插件

Pipeline Stage View Plugin

需要专业的网站建设服务?

联系我们获取免费的网站建设咨询和方案报价,让我们帮助您实现业务目标

立即咨询